Tests fail to run on BrowserStack with all Parallels in use error
Learn how to resolve the All parallel tests are currently in use
error message.
Issue
When you run your tests on BrowserStack, you may encounter the following error:
All parallel tests are currently in use, including the queued tests. Please wait to finish or upgrade your plan to add more sessions.
Cause
This error can occur due to any of the following reasons:
- You tried to run a test, but the number of parallel and queued tests is already full.
- You or the sub-team you are assigned to doesn’t have parallels assigned.
Resolution/Workaround
You can try the following resolutions:
Check available parallel and queued tests
Before you run any parallel test on BrowserStack, check the number of available parallel and queued tests using the Plan API
:
# Find the available number of parallel and queued tests
curl -u "{your_username}:{your_access_key}" https://api.browserstack.com/app-automate/plan.json
The response to this command is as follows:
{
"automate_plan":"App Automate",
"parallel_sessions_running":5,
"team_parallel_sessions_max_allowed":5,
"parallel_sessions_max_allowed":5,
"queued_sessions":5,
"queued_sessions_max_allowed":5
}
Observe the response and check the following table:
Issue | Cause | Resolution |
---|---|---|
parallel_sessions_running is equal to team_parallel_sessions_max_allowed , and queued_sessions is equal to queued_sessions_max_allowed
|
All your allocated parallel(5) and queued(5) tests are currently in use | Use the Plan API to check whether you have parallels or queues available, before sending a session to BrowserStack.If you want additional parallels to improve the speed of your build, contact us. |
- To avoid tests from going into the queue, we recommend that you periodically use the
Plan API
to learn about the available parallels. - Use the same BrowserStack user credentials to send a Plan API request and to trigger your tests so that you can plan parallels efficiently.
Check product access
On the App Automate dashboard, click User Management and then click the Users tab and search for a username to verify the products that you can access.
For access to any other product, contact us.
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